summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2018-05-30 07:20:17 +0200
committerStanislaw Halik <sthalik@misaki.pl>2018-05-30 07:20:17 +0200
commit9f1595131f15e47d12c6a633e45d8ef837bddd75 (patch)
treed02dc02685b67ad24d13e05bea8fbe5c46c20f51 /CMakeLists.txt
parent73032cf0e8df0b942b3617cd06f1d50078ee085a (diff)
cmake: binutils fixes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3277fd4d..dc96a504 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,12 @@
# OTHER DEALINGS IN THE SOFTWARE.
set(CMAKE_DISABLE_IN_SOURCE_BUILD ON)
+
+set(CMAKE_C_LINKER_PREFERENCE CXX)
+set(CMAKE_CXX_LINKER_PREFERENCE CXX)
+set(CMAKE_C_LINKER_PREFERENCE_PROPAGATES ON)
+set(CMAKE_CXX_LINKER_PREFERENCE_PROPAGATES ON)
+
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/")
include(opentrack-mrproper)