summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2014-07-11 12:31:27 +0200
committerStanislaw Halik <sthalik@misaki.pl>2014-07-11 12:31:27 +0200
commitc76dc2c8cea78285460fea7f98b9c64904242f9a (patch)
treeb541678d6049bd7ec0172465766bab1dbeeb6b8d /CMakeLists.txt
parentfff9b880283f26d226eb1aa1a3bebf8a06d7d21b (diff)
fix symbol visibility issue
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2b2e9f99..21a865f4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,8 @@ if(CMAKE_COMPILER_IS_GNUCXX AND NOT APPLE)
endif()
endif()
+add_definitions(-DOPENTRACK_MAIN)
+
if(APPLE)
set(apple-frameworks "-stdlib=libc++ -framework Cocoa -framework CoreFoundation -lobjc -lz -framework Carbon")
set(CMAKE_SHARED_LINKER_FLAGS " ${apple-frameworks} ${CMAKE_SHARED_LINKER_FLAGS}")
@@ -549,7 +551,6 @@ if(SDK_GOOGLE_BREAKPAD)
"${SDK_GOOGLE_BREAKPAD}/src/client/windows/Release/lib/common.lib")
endif()
endif()
-set_target_properties(opentrack PROPERTIES COMPILE_FLAGS -DOPENTRACK_MAIN)
# make install