summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2013-10-25 14:44:15 +0200
committerStanislaw Halik <sthalik@misaki.pl>2013-10-25 14:44:15 +0200
commitf5d310a7da41456582e85e67376bcda99321a169 (patch)
tree08fbaac62735aa06fb337a2a5bd827550de685a6 /CMakeLists.txt
parent5f8f39873d8f1caddc6eca9ccc765e37176012c1 (diff)
Fix installer versionopentrack-2.0a7
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 08d1f64a..2f999144 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -574,6 +574,8 @@ if(UNIX)
endif()
add_executable(opentrack ${opentrack-win32-executable} ${opentrack-bin-c} ${opentrack-bin-h} ${opentrack-bin-moc} ${opentrack-bin-uih} ${opentrack-bin-rcc})
set_target_properties(opentrack PROPERTIES COMPILE_DEFINITIONS OPENTRACK_VERSION=\"${OPENTRACK__COMMIT}\")
+set(OPENTRACK_COMMIT_VERSION \"${OPENTRACK__COMMIT}\")
+configure_file("${CMAKE_SOURCE_DIR}/opentrack-version.h" "${CMAKE_BINARY_DIR}/opentrack-version.h" @ONLY NEWLINE_STYLE UNIX)
if(UNIX)
target_link_libraries(opentrack opentrack-qxt-mini)
endif()