summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2016-05-16 13:10:34 +0200
committerStanislaw Halik <sthalik@misaki.pl>2016-05-16 13:10:34 +0200
commit7900281e56efcd88a538905ac434da530a231d4b (patch)
tree472ca3384a1187b13de29a3154f7e4a64879e23b /CMakeLists.txt
parent3e4c6f2977d8a5515229c79d969392de3cafbb4b (diff)
cmake: check for build directory sanity before declaring the project
This does the check before compiler tests, spewing less crapola into the source directory.
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1d8d5aef..5213721f 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,9 +1,10 @@
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_SOURCE_DIR}/cmake/)
+include(opentrack-check-build-directory)
+
project(opentrack)
cmake_minimum_required(VERSION 2.8.11)
-set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_SOURCE_DIR}/cmake/)
include(CMakeParseArguments)
-include(opentrack-check-build-directory)
include(opentrack-policy)
include(opentrack-qt)
include(opentrack-platform)