summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2017-03-27 00:36:31 +0200
committerStanislaw Halik <sthalik@misaki.pl>2017-03-27 00:36:31 +0200
commit87ec56fd4725007dea2875b796b635f722b62c7c (patch)
treeecdd295220e0740df091da02d362d9134c674105 /CMakeLists.txt
parent7c072cd1b62998c763a6c3e56ccd17c3f89f556c (diff)
cmake: remove -DNDEBUG from cxxflags automatically
User came complain why ndebug-guard.hpp #error'ed out.
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 51d037c7..276a5cae 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -78,3 +78,7 @@ endforeach()
merge_translations()
install_sources()
+
+foreach(k C CXX)
+ fix_flags(${k} "DNDEBUG" "")
+endforeach()