summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2014-06-11 17:41:44 +0200
committerStanislaw Halik <sthalik@misaki.pl>2014-06-11 17:41:44 +0200
commitafbca18600670b900eaa0ab30a296428d66eaaaf (patch)
tree904bbca04084000503a9dffc08cba413edeaf007 /CMakeLists.txt
parent1603c540fa807b7ff3a2384bf800ba83c61ccdeb (diff)
implement a high-precision timer
untested on OSX so far Signed-off-by: Stanislaw Halik <sthalik@misaki.pl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 40682474..7e101bad 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -526,6 +526,10 @@ endif()
link_with_dinput8(opentrack)
+if(CMAKE_SYSTEM STREQUAL LINUX)
+ link_libraries(rt)
+endif()
+
if(MSVC)
SET_TARGET_PROPERTIES(opentrack PROPERTIES LINK_FLAGS "/ENTRY:mainCRTStartup")
endif()