summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2015-07-06 09:09:18 +0200
committerStanislaw Halik <sthalik@misaki.pl>2015-07-06 09:09:18 +0200
commit1388d95ecf71d517d24ccb6713641220a5553e4a (patch)
treeb06b62465c30bc9d77598de2d9bad0e30362a585 /CMakeLists.txt
parent68c8278b25b417c21dfbb0e3974044a36dfc151e (diff)
simconnect: use event handle without calldispatch in a loop
We aren't supposed to calldispatch in a loop, since it locks up FSX. Use calldispatch only if FSX signals us that an event has been received. This might fix slowness reported in #174.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 448375f3..c45163dc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -304,7 +304,7 @@ endif()
if(SDK_SIMCONNECT)
opentrack_library(opentrack-proto-simconnect ftnoir_protocol_sc)
- target_link_libraries(opentrack-proto-simconnect ${SDK_SIMCONNECT}/lib/SimConnect.lib winmm)
+ target_link_libraries(opentrack-proto-simconnect ${SDK_SIMCONNECT}/lib/SimConnect.lib)
include_directories(opentrack-proto-simconnect SYSTEM PUBLIC ${SDK_SIMCONNECT}/inc)
endif()