summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2016-11-04 18:40:24 +0100
committerStanislaw Halik <sthalik@misaki.pl>2016-11-04 19:48:09 +0100
commitf08dc187499d2895f50f7e2e7e99bf698b0c0738 (patch)
tree7b15638804b92fb99ffa07dc45fb29aef4d7cd80 /CMakeLists.txt
parenta308e5cd2c6769750f8f6b4e486a8e66b591dafe (diff)
cmake, main: add translation support
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c7329c92..a953c1e7 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,9 +28,13 @@ include(opentrack-build)
project(opentrack)
cmake_minimum_required(VERSION 2.8.11)
+set_property(GLOBAL PROPERTY opentrack-all-modules "")
+set_property(GLOBAL PROPERTY opentrack-all-source-dirs "")
+set(opentrack-all-translations pl_PL ru_RU)
+
+include(opentrack-policy)
include(opentrack-word-size)
include(opentrack-hier)
-include(opentrack-policy)
include(opentrack-qt)
include(opentrack-platform)
include(opentrack-boilerplate)
@@ -70,3 +74,5 @@ foreach(i ${opentrack-subprojects})
get_filename_component(i ${i} DIRECTORY)
add_subdirectory(${i})
endforeach()
+
+merge_translations()