summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2014-06-05 14:09:51 +0200
committerStanislaw Halik <sthalik@misaki.pl>2014-06-05 14:09:51 +0200
commit09ef6d7c5e33beb16f81871b3a776d479355b4ac (patch)
treed4908c3ac32f195ecb1260aa31c2f1a7d21cd8d1 /CMakeLists.txt
parent90b767d71f191ba758bfccfd2eb65fa81b653a52 (diff)
Only enable libevdev on Linux. Default to it enabled.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7e268a65..44e853af 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -87,8 +87,8 @@ if(WIN32 AND DEFINED MSVC_VERSION AND NOT ${MSVC_VERSION} LESS 1700)
SET (CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} /SAFESEH:NO")
endif()
-if(UNIX)
- SET(SDK_LIBEVDEV "" CACHE PATH "libevdev SDK path")
+if(CMAKE_SYSTEM_NAME STREQUAL Linux)
+ SET(SDK_LIBEVDEV "/usr" CACHE PATH "libevdev install prefix")
endif()
if(WIN32)