summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorokdshin <kokuzen@gmail.com>2014-06-05 19:33:56 +0900
committerokdshin <kokuzen@gmail.com>2014-06-05 20:47:46 +0900
commit8a386b16ed0619d25f04f5b3a85205abea7b184e (patch)
tree91f8f21138d0a3a3f188045436f0145c4f25911c /CMakeLists.txt
parent564384f83c376a9624662a1eab9cec9caca16493 (diff)
remove SDK_ENABLE_LIBEVDEV macro and simplify sdk libevdev config
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c2763dec..7e268a65 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,11 +88,9 @@ if(WIN32 AND DEFINED MSVC_VERSION AND NOT ${MSVC_VERSION} LESS 1700)
endif()
if(UNIX)
- set(SDK_ENABLE_LIBEVDEV FALSE CACHE BOOL "libevdev virtual joystick protocol support (probably Linux only)")
- if(SDK_ENABLE_LIBEVDEV)
- SET(SDK_LIBEVDEV "" CACHE PATH "libevdev SDK path")
- endif()
+ SET(SDK_LIBEVDEV "" CACHE PATH "libevdev SDK path")
endif()
+
if(WIN32)
SET(SDK_CONSOLE_DEBUG FALSE CACHE BOOL "Console build")
endif()
@@ -332,7 +330,7 @@ if(SDK_VJOY)
endif()
endif()
-if(SDK_ENABLE_LIBEVDEV)
+if(SDK_LIBEVDEV)
include_directories(${SDK_LIBEVDEV})
opentrack_library(opentrack-proto-libevdev)
target_link_libraries(opentrack-proto-libevdev evdev)