summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2014-06-06 10:07:36 +0200
committerStanislaw Halik <sthalik@misaki.pl>2014-06-06 10:07:36 +0200
commit922de20236423932edc5c4ff28e697b7c32c8a45 (patch)
treef7221d8737ede249c50c378bb4c007e1bbd2d743 /CMakeLists.txt
parent09ef6d7c5e33beb16f81871b3a776d479355b4ac (diff)
Revert cmake libevdev changes
It doesn't do what it's supposed to. Doesn't point to prefix, only relevant for include path. Previous setup isn't that bad so revert for now.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 44e853af..40682474 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -87,10 +87,9 @@ if(WIN32 AND DEFINED MSVC_VERSION AND NOT ${MSVC_VERSION} LESS 1700)
SET (CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} /SAFESEH:NO")
endif()
-if(CMAKE_SYSTEM_NAME STREQUAL Linux)
- SET(SDK_LIBEVDEV "/usr" CACHE PATH "libevdev install prefix")
+if(UNIX)
+ set(SDK_ENABLE_LIBEVDEV FALSE CACHE BOOL "libevdev virtual joystick protocol support (probably Linux only)")
endif()
-
if(WIN32)
SET(SDK_CONSOLE_DEBUG FALSE CACHE BOOL "Console build")
endif()
@@ -330,8 +329,7 @@ if(SDK_VJOY)
endif()
endif()
-if(SDK_LIBEVDEV)
- include_directories(${SDK_LIBEVDEV})
+if(SDK_ENABLE_LIBEVDEV)
opentrack_library(opentrack-proto-libevdev)
target_link_libraries(opentrack-proto-libevdev evdev)
endif()