summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2015-07-23 11:07:17 +0200
committerStanislaw Halik <sthalik@misaki.pl>2015-07-23 11:07:17 +0200
commitb0f6b7de714e20a2f36d56a01c99522722218657 (patch)
treee376ef88a4ccfdc6847ae2f2ba9f21a6f9289d3b /CMakeLists.txt
parent94e6b0452ffd2011657b04c0521a4f84fdfa5e4d (diff)
no longer add extra file to modules
Modules now link to opentrack-api so this isn't needed
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 16f779d3..3648e58c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -76,11 +76,8 @@ endif()
set_property(GLOBAL PROPERTY USE_FOLDERS OFF)
-# qt broken as usual
-set(EXTRA-MOCS opentrack/options.hpp)
-
macro(opentrack_module n dir)
- file(GLOB ${n}-c ${dir}/*.cpp ${dir}/*.c ${dir}/*.h ${dir}/*.hpp ${EXTRA-MOCS})
+ file(GLOB ${n}-c ${dir}/*.cpp ${dir}/*.c ${dir}/*.h ${dir}/*.hpp)
file(GLOB ${n}-res ${dir}/*.rc)
foreach(f ${n}-res)
set_source_files_properties(${f} PROPERTIES LANGUAGE RC)