summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2015-03-31 06:00:48 +0200
committerStanislaw Halik <sthalik@misaki.pl>2015-03-31 06:00:48 +0200
commitdaae1cf1241b0e2355804a7e5be17eb24af76fe5 (patch)
tree473cd0defeab07bc86ca01ce80e16e08840f86d2 /CMakeLists.txt
parentc8599b51831c925cb69105ec6f8b5bcfc253b37c (diff)
hatire: hook up into the build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 33b2c7a7..c7e3cedc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,7 +24,8 @@ set(CMAKE_POSITION_INDEPENDENT_CODE ON)
find_package(OpenCV)
include_directories(${OpenCV_INCLUDE_DIRS})
-find_package(Qt5 REQUIRED COMPONENTS Core Xml Network Widgets Gui ${maybe-serial-port} QUIET)
+find_package(Qt5 REQUIRED COMPONENTS Core Xml Network Widgets Gui QUIET)
+find_package(Qt5 COMPONENTS SerialPort QUIET)
include_directories(${Qt5Core_INCLUDE_DIRS} ${Qt5Xml_INCLUDE_DIRS} ${Qt5Gui_INCLUDE_DIRS} ${Qt5Widgets_INCLUDE_DIRS} ${Qt5Network_INCLUDE_DIRS})
add_definitions(${Qt5Core_DEFINITIONS} ${Qt5Xml_DEFINITIONS} ${Qt5Gui_DEFINITIONS} ${Qt5Widgets_DEFINITIONS} ${Qt5Network_DEFINITIONS})
@@ -292,6 +293,12 @@ if(WIN32)
opentrack_library(opentrack-tracker-joystick ftnoir_tracker_joystick)
endif()
+if(Qt5SerialPort_FOUND)
+ opentrack_library(opentrack-tracker-hatire ftnoir_tracker_hatire)
+ include_directories(${Qt5SerialPort_INCLUDE_DIRS})
+ target_link_libraries(opentrack-tracker-hatire ${Qt5SerialPort_LIBRARIES})
+endif()
+
if(SDK_WINE_PREFIX)
opentrack_library(opentrack-proto-wine ftnoir_protocol_wine)
target_link_libraries(opentrack-proto-wine opentrack-compat opentrack-csv)