summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2017-07-16 14:32:53 +0200
committerStanislaw Halik <sthalik@misaki.pl>2017-07-16 14:32:53 +0200
commit2a4e1bb14a524e765158fd5f53d93e609580265f (patch)
tree35f1888994fce162033961722754cb8d2a2ce85c /CMakeLists.txt
parentb8bcaa92d0fe795c2da2a70a33390274ab03d0cd (diff)
cmake: don't cache initial translation list
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ba838a3e..e5277d73 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -31,7 +31,11 @@ include(opentrack-policy NO_POLICY_SCOPE)
set_property(GLOBAL PROPERTY opentrack-all-modules "")
set_property(GLOBAL PROPERTY opentrack-all-source-dirs "")
-set(opentrack_all-translations "nl_NL;ru_RU;stub" CACHE STRING "")
+set(opentrack_all-translations "" CACHE STRING "Leave empty for default")
+
+if(".${opentrack_all-translations}" STREQUAL ".")
+ set(opentrack_all-translations "nl_NL;ru_RU;stub")
+endif()
include(opentrack-word-size)
include(opentrack-hier)