summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2017-08-24 11:17:58 +0200
committerStanislaw Halik <sthalik@misaki.pl>2017-08-25 11:47:59 +0200
commitee513046912d5267265246378713334b2ea2d1f1 (patch)
treed4127e9a952548dbc5e9763e8317d83e8b90ef80 /CMakeLists.txt
parent65e895dfb662c3fd87e37628358f3bd955eb4b5f (diff)
cmake: move to separate file
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt20
1 files changed, 1 insertions, 19 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 201b2110..d5e45c64 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,25 +28,7 @@ include(opentrack-mrproper)
project(opentrack)
cmake_minimum_required(VERSION 2.8.11)
include(opentrack-policy NO_POLICY_SCOPE)
-
-include(CMakeDetermineCCompiler)
-include(CMakeDetermineCXXCompiler)
-
-if(WIN32)
- set(__sdk_username "$ENV{USERNAME}")
-else()
- set(__sdk_username "$ENV{USER}")
-endif()
-
-if(".${__sdk_username}" STREQUAL ".")
- set(__sdk_username "(I-have-no-name)")
-endif()
-
-set(__sdk_paths_filename "${CMAKE_SOURCE_DIR}/sdk-paths-${__sdk_username}@${CMAKE_CXX_COMPILER_ID}.cmake")
-
-if(EXISTS "${__sdk_paths_filename}")
- include("${__sdk_paths_filename}")
-endif()
+include(opentrack-load-user-settings)
set_property(GLOBAL PROPERTY opentrack-all-modules "")
set_property(GLOBAL PROPERTY opentrack-all-source-dirs "")