summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorokdshin <kokuzen@gmail.com>2014-05-21 18:08:04 +0900
committerokdshin <kokuzen@gmail.com>2014-05-21 18:08:04 +0900
commit89e040931523f3b90a44f711a7e76f3b189a2eb5 (patch)
tree1cbb52850c1375e8a9e497c5f7fe39e471c07b42 /CMakeLists.txt
parent5296a52fec9288f22aaf6c4a5f8141d8a36014fc (diff)
add SDK_LIBEVDEV to enable users to select libevdev path.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 40682474..c2763dec 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,7 +88,10 @@ if(WIN32 AND DEFINED MSVC_VERSION AND NOT ${MSVC_VERSION} LESS 1700)
endif()
if(UNIX)
- set(SDK_ENABLE_LIBEVDEV FALSE CACHE BOOL "libevdev virtual joystick protocol support (probably Linux only)")
+ set(SDK_ENABLE_LIBEVDEV FALSE CACHE BOOL "libevdev virtual joystick protocol support (probably Linux only)")
+ if(SDK_ENABLE_LIBEVDEV)
+ SET(SDK_LIBEVDEV "" CACHE PATH "libevdev SDK path")
+ endif()
endif()
if(WIN32)
SET(SDK_CONSOLE_DEBUG FALSE CACHE BOOL "Console build")
@@ -330,6 +333,7 @@ if(SDK_VJOY)
endif()
if(SDK_ENABLE_LIBEVDEV)
+ include_directories(${SDK_LIBEVDEV})
opentrack_library(opentrack-proto-libevdev)
target_link_libraries(opentrack-proto-libevdev evdev)
endif()