summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2014-10-23 07:54:40 +0200
committerStanislaw Halik <sthalik@misaki.pl>2014-10-23 07:54:40 +0200
commit04e844d8b4353f71f228659a5bf559c4b7d5c4b3 (patch)
tree733f1061b46ea29ecbd7fce9bcb3891116cb0f3f /CMakeLists.txt
parent0c9992c5fd5ea3d96d4b465c3c09b85c447ccc55 (diff)
Fix x-plane plugin copy-paste breakage
Reported-by @runningman84 Issue: #89
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 01c5eba5..118fdb93 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -204,7 +204,7 @@ opentrack_module(freetrackclient freetrackclient)
if(SDK_XPLANE)
# probably librt already included
- add_library(opentrack-xplane-plugin STATIC ${opentrack-xplane-plugin-c})
+ add_library(opentrack-xplane-plugin SHARED ${opentrack-xplane-plugin-c})
if(CMAKE_COMPILER_IS_GNUCXX OR CMAKE_COMPILER_IS_GNUCC AND NOT APPLE)
SET_TARGET_PROPERTIES(opentrack-xplane-plugin
PROPERTIES LINK_FLAGS