summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2013-10-11 15:23:48 +0200
committerStanislaw Halik <sthalik@misaki.pl>2013-10-11 15:23:48 +0200
commit10e285066e8249850ea8f9007e2313b5fdbe9fbd (patch)
tree265fb3a87d55598c10b9fde0a3dfd61d3e193eaf /CMakeLists.txt
parentda2158b8bf411c8d4a83895c9c7519cb45cb34ac (diff)
add hydra plats linux/osx
Signed-off-by: Stanislaw Halik <sthalik@misaki.pl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 9 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d235f0e9..0fd9fda0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -534,11 +534,16 @@ endif()
else()
set(underscore-sixtyfour)
endif()
- if (APPLE)
- target_link_libraries(opentrack-tracker-hydra "${SDK_HYDRA}/lib/osx${underscore-sixtyfour}/release_dll/libsixense${underscore-sixtyfour}.dylib" "${SDK_HYDRA}/lib/osx${underscore-sixtyfour}/release_dll/libsixense_utils${underscore-sixtyfour}.dylib")
- else() # NB assume linux binary-compat, e.g. freebsd
- target_link_libraries(opentrack-tracker-hydra "${SDK_HYDRA}/lib/linux${underscore-sixtyfour}/release_dll/libsixense${underscore-sixtyfour}.so" "${SDK_HYDRA}/lib/linux${underscore-sixtyfour}/release_dll/libsixense_utils${underscore-sixtyfour}.so")
+ if(APPLE)
+ set(underscore-dll _dll)
+ set(soext dylib)
+ set(sixense-plat osx)
+ else()
+ set(underscore-dll)
+ set(soext so)
+ set(sixense-plat linux)
endif()
+ target_link_libraries(opentrack-tracker-hydra "${SDK_HYDRA}/lib/${sixense-plat}${underscore-sixtyfour}/release${underscore-dll}/libsixense${underscore-sixtyfour}.${soext}" "${SDK_HYDRA}/lib/${sixense-plat}${underscore-sixtyfour}/release${underscore-dll}/libsixense_utils${underscore-sixtyfour}.${soext}")
endif()
if(CMAKE_COMPILER_IS_GNUCXX OR CMAKE_COMPILER_IS_GNUCC)
SET_TARGET_PROPERTIES(opentrack-tracker-hydra