summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2013-10-11 15:31:05 +0200
committerStanislaw Halik <sthalik@misaki.pl>2013-10-11 15:31:05 +0200
commit9bfdc0779ef425113589604652c834e1ae8432e0 (patch)
treeb89e406a5a6ef2de2b70563bea720e8e87f5bb01 /CMakeLists.txt
parent10e285066e8249850ea8f9007e2313b5fdbe9fbd (diff)
There are only shared libraries for non-win32 :(
Signed-off-by: Stanislaw Halik <sthalik@misaki.pl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0fd9fda0..f263f47d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -543,6 +543,10 @@ endif()
set(soext so)
set(sixense-plat linux)
endif()
+ install(FILES
+ "${SDK_HYDRA}/lib/${sixense-plat}${underscore-sixtyfour}/release${underscore-dll}/libsixense${underscore-sixtyfour}.${soext}"
+ "${SDK_HYDRA}/lib/${sixense-plat}${underscore-sixtyfour}/release${underscore-dll}/libsixense_utils${underscore-sixtyfour}.${soext}"
+ DESTINATION .)
target_link_libraries(opentrack-tracker-hydra "${SDK_HYDRA}/lib/${sixense-plat}${underscore-sixtyfour}/release${underscore-dll}/libsixense${underscore-sixtyfour}.${soext}" "${SDK_HYDRA}/lib/${sixense-plat}${underscore-sixtyfour}/release${underscore-dll}/libsixense_utils${underscore-sixtyfour}.${soext}")
endif()
if(CMAKE_COMPILER_IS_GNUCXX OR CMAKE_COMPILER_IS_GNUCC)