summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2013-12-29 03:33:50 +0100
committerStanislaw Halik <sthalik@misaki.pl>2013-12-29 03:33:50 +0100
commitfbef92577584a6000cdbcffa5744b77d28f1dc0c (patch)
treedc8358a0fc3b3a39d1806c332d7b8a19b77670c6 /CMakeLists.txt
parentfa54d5a4f8a0bf73cad7ebdd3895b8a7467868e6 (diff)
unbitrot freetrack proto
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eff5edaf..8e9ade02 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -499,11 +499,9 @@ if(WIN32)
add_library(opentrack-proto-win32-mouse SHARED ${opentrack-proto-win32-mouse-c} ${opentrack-proto-win32-mouse-h} ${opentrack-proto-win32-mouse-moc} ${opentrack-proto-win32-mouse-uih} ${opentrack-proto-win32-mouse-rcc})
target_link_libraries(opentrack-proto-win32-mouse ${MY_QT_LIBS})
+ add_library(freetrackclient SHARED ${opentrack-freetrack-c} ${opentrack-freetrack-h})
if(CMAKE_COMPILER_IS_GNUCC)
- add_library(freetrackclient SHARED ${opentrack-freetrack-c} ${opentrack-freetrack-h} "${CMAKE_SOURCE_DIR}/freetrackclient/freetrackclient.def")
- set_target_properties(freetrackclient PROPERTIES LINK_FLAGS "-Wl,--enable-stdcall-fixup")
- else()
- add_library(freetrackclient SHARED ${opentrack-freetrack-c} ${opentrack-freetrack-h})
+ set_target_properties(freetrackclient PROPERTIES LINK_FLAGS "-Wl,--enable-stdcall-fixup -fno-lto -Wl,-kill-at" PREFIX "" COMPILE_FLAGS "-fno-lto")
endif()
endif()