summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2014-09-22 15:21:06 +0200
committerStanislaw Halik <sthalik@misaki.pl>2014-09-22 15:21:06 +0200
commit083fd59b06aa9f9124e8161d915cc596e83f2589 (patch)
tree4ba0197fe3228eafeef729448fd089cf3d76638a /CMakeLists.txt
parent45d89cfd526bf7fa3f7865f2e78f10cd9a85a2f6 (diff)
wine: setup dependencies properly
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b1bbf4ba..d6c28682 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -320,23 +320,23 @@ if(SDK_WINE_PREFIX)
opentrack_library(opentrack-proto-wine)
target_link_libraries(opentrack-proto-wine opentrack-compat opentrack-csv)
if(NOT SDK_WINE_NO_WRAPPER)
- set(my-rt -lrt)
- if(APPLE)
- set(my-rt)
- endif()
+ set(my-rt -lrt)
+ if(APPLE)
+ set(my-rt)
+ endif()
+ file(GLOB wine-deps "${CMAKE_SOURCE_DIR}/ftnoir_protocol_wine/*.cxx")
add_custom_command(
OUTPUT opentrack-wrapper-wine.exe.so
- DEPENDS "${CMAKE_SOURCE_DIR}/ftnoir_protocol_wine/opentrack-wrapper-wine-main.cxx"
- "${CMAKE_SOURCE_DIR}/ftnoir_protocol_wine/opentrack-wrapper-wine-posix.cxx"
- "${CMAKE_SOURCE_DIR}/ftnoir_protocol_wine/opentrack-wrapper-wine-windows.cxx"
- COMMAND "${SDK_WINE_PREFIX}/bin/wineg++" -g -O2 -m32 -o
+ DEPENDS ${wine-deps}
+ COMMAND "${SDK_WINE_PREFIX}/bin/wineg++" -g -O2 -m32 -std=c++11 -o
opentrack-wrapper-wine.exe -I "${CMAKE_SOURCE_DIR}"
"${CMAKE_SOURCE_DIR}/ftnoir_protocol_wine/opentrack-wrapper-wine-main.cxx"
"${CMAKE_SOURCE_DIR}/ftnoir_protocol_wine/opentrack-wrapper-wine-posix.cxx"
"${CMAKE_SOURCE_DIR}/ftnoir_protocol_wine/opentrack-wrapper-wine-windows.cxx"
${my-rt})
add_custom_target(wine-wrapper ALL DEPENDS opentrack-wrapper-wine.exe.so)
- add_dependencies(wine-wrapper opentrack-compat opentrack-proto-wine)
+ add_dependencies(opentrack-proto-wine wine-wrapper)
+ add_dependencies(wine-wrapper opentrack-compat)
endif()
endif()