summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@tehran.lain.pl>2020-01-13 15:02:44 +0100
committerGitHub <noreply@github.com>2020-01-13 15:02:44 +0100
commit50f23dc21fce9d382893ad77dc29fd343ee2134c (patch)
tree663c0c38fc91b3d021ad8d38ba8ea5b7c0e5b647 /CMakeLists.txt
parentfb994308266093382fffecb8a3fd2645ab811117 (diff)
parent2d709bb4755305342b79a1574c90b2be348b4c4d (diff)
Merge pull request #1006 from rvt/osx-build-fix
OSX Build fixes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a7a95d2f..448d7667 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -93,8 +93,15 @@ function(otr_add_subdirs)
foreach(k ${_globbed})
get_filename_component(k "${k}" DIRECTORY)
- add_subdirectory("${k}")
+ # we want to compile macosx last so we can run proper install scripts
+ if (k MATCHES "macosx$")
+ set(o ${k})
+ else()
+ add_subdirectory("${k}")
+ endif()
endforeach()
+ # Add macosx last
+ add_subdirectory("${o}")
endfunction()
otr_add_subdirs()