summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorR. van Twisk <ries.van.twisk@ing.com>2019-12-19 21:07:19 +0100
committerR. van Twisk <ries.van.twisk@ing.com>2019-12-19 21:07:19 +0100
commit96316119fd57b1d5acdfc0ff51e1766a9311f11f (patch)
treed4f82397cbfc4427b39901023cc350ac9673965f /CMakeLists.txt
parent8d29288ecd592bae5b0bc2951cd44c7400e36654 (diff)
Fix bundle creation OSX
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a7a95d2f..448d7667 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -93,8 +93,15 @@ function(otr_add_subdirs)
foreach(k ${_globbed})
get_filename_component(k "${k}" DIRECTORY)
- add_subdirectory("${k}")
+ # we want to compile macosx last so we can run proper install scripts
+ if (k MATCHES "macosx$")
+ set(o ${k})
+ else()
+ add_subdirectory("${k}")
+ endif()
endforeach()
+ # Add macosx last
+ add_subdirectory("${o}")
endfunction()
otr_add_subdirs()