summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2015-10-29 11:05:27 +0100
committerStanislaw Halik <sthalik@misaki.pl>2015-10-29 11:05:27 +0100
commit232c2ba8aca7900eaa950c48813ddfaca8a749a8 (patch)
treec08da2e256be5b5e80fac3f611f956fef275f142 /CMakeLists.txt
parent7128fe581ee2ed25fe8e43ec2be9644e2539e2ad (diff)
parent06a0a71f27134a86d19612fd786bfc2ca6f4c4bb (diff)
Merge branch 'unstable' into trackhat
* unstable: fix vtable mess xargs sed -i -e s/'FaceTrackNoIR Error/Error/g' support rift 0.2.5, 0.4.2, 0.8.0 rift: finish 0.2.5 support buffer flush rename "clientfiles/" to "contrib/" as customary add dropbox uploader to contrib add description on wiki for camera offset
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt18
1 files changed, 1 insertions, 17 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a7c64144..cdd69a57 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -185,18 +185,8 @@ endif()
if(LINUX OR APPLE)
set(SDK_XPLANE "" CACHE PATH "Path to X-Plane SDK")
- set(SDK_ENABLE_LIBEVDEV FALSE CACHE BOOL "libevdev virtual joystick protocol support")
endif()
-SET(SDK_HYDRA "" CACHE PATH "libSixense path for Razer Hydra")
-SET(SDK_HYDRA_AMD64 FALSE CACHE BOOL "whether libSixense is amd64 (else ia-32)")
-SET(SDK_RIFT "" CACHE PATH "libOVR path for Oculus Rift")
-
-set(SDK_ARUCO_LIBPATH "" CACHE FILEPATH "Aruco paper marker tracker static library path")
-
-set(SDK_HT "" CACHE FILEPATH "Path to headtracker library")
-set(SDK_HT_FLANDMARK "" CACHE FILEPATH "Path to flandmark library for headtracker")
-
if(WIN32)
set(SDK_FSUIPC "" CACHE PATH "FSUIPC for older MS FSX path")
endif()
@@ -362,13 +352,7 @@ endif()
opentrack_library(opentrack-proto-udp ftnoir_protocol_ftn)
-if(Qt5SerialPort_FOUND AND FALSE)
- opentrack_library(opentrack-tracker-hatire ftnoir_tracker_hatire)
- target_link_libraries(opentrack-tracker-hatire ${Qt5SerialPort_LIBRARIES})
- target_include_directories(opentrack-tracker-hatire SYSTEM PUBLIC ${Qt5SerialPort_INCLUDE_DIRS})
-endif()
-
-if(SDK_WINE_PREFIX AND FALSE)
+if(SDK_WINE_PREFIX)
opentrack_library(opentrack-proto-wine ftnoir_protocol_wine)
target_link_libraries(opentrack-proto-wine opentrack-compat opentrack-csv)
if(NOT SDK_WINE_NO_WRAPPER)