summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2015-07-23 11:07:17 +0200
committerStanislaw Halik <sthalik@misaki.pl>2015-07-24 09:20:19 +0200
commita2682c3265c4f891e7baf740c08d19e01cd6d8d8 (patch)
tree999552c25f44712aa927168b0a6f8c6788b18052 /CMakeLists.txt
parenta3c6f93f18b069afa8d8c854e25c52894863940d (diff)
no longer add extra file to modules
Modules now link to opentrack-api so this isn't needed
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ee0e932c..19fb2668 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -76,11 +76,8 @@ endif()
set_property(GLOBAL PROPERTY USE_FOLDERS OFF)
-# qt broken as usual
-set(EXTRA-MOCS opentrack/options.hpp)
-
macro(opentrack_module n dir)
- file(GLOB ${n}-c ${dir}/*.cpp ${dir}/*.c ${dir}/*.h ${dir}/*.hpp ${EXTRA-MOCS})
+ file(GLOB ${n}-c ${dir}/*.cpp ${dir}/*.c ${dir}/*.h ${dir}/*.hpp)
file(GLOB ${n}-res ${dir}/*.rc)
foreach(f ${n}-res)
set_source_files_properties(${f} PROPERTIES LANGUAGE RC)