summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2013-09-14 23:46:06 +0200
committerStanislaw Halik <sthalik@misaki.pl>2013-09-14 23:46:06 +0200
commit0e2632a716297a3811caa8117b3ec8f1046a9a7e (patch)
treee66519209c5298934d87cd151c9fc854b759e267 /CMakeLists.txt
parentbab1d6596f1a8404e88e2d93092e7be1f9d4ca93 (diff)
Unbreak mingw-w64 build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 11 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6e5b6978..3256cb9b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -81,13 +81,13 @@ if(NOT SDK_FACEAPI_ONLY)
endif()
if(WIN32)
- ENABLE_LANGUAGE(RC)
if(CMAKE_COMPILER_IS_GNUCXX OR CMAKE_COMPILER_IS_GNUCC)
- set(CMAKE_RC_COMPILER_INIT windres)
+ #set(CMAKE_RC_COMPILER_INIT windres)
SET(CMAKE_RC_COMPILE_OBJECT "<CMAKE_RC_COMPILER> <FLAGS> -O coff <DEFINES> -i <SOURCE> -o <OBJECT>")
else()
- set(CMAKE_RC_COMPILER_INIT rc)
+ #set(CMAKE_RC_COMPILER_INIT rc)
endif()
+ ENABLE_LANGUAGE(RC)
endif(WIN32)
if(SDK_FSUIPC AND WIN32)
@@ -371,7 +371,14 @@ endif()
add_library(opentrack-proto-win32-mouse SHARED ${opentrack-proto-win32-mouse-c} ${opentrack-proto-win32-mouse-moc} ${opentrack-proto-win32-mouse-uih} ${opentrack-proto-win32-mouse-rcc})
target_link_libraries(opentrack-proto-win32-mouse ${MY_QT_LIBS})
- add_library(freetrackclient SHARED ${opentrack-freetrack-c})
+ add_library(freetrackclient SHARED ${opentrack-freetrack-c})
+ if(CMAKE_COMPILER_IS_GNUCC)
+ set_target_properties(freetrackclient PROPERTIES
+ LINK_FLAGS "-Wl,--kill-at"
+ LIBRARY_OUTPUT_NAME "freetrackclient.dll"
+ PREFIX "" SUFFIX ""
+ )
+ endif()
endif()
add_library(opentrack-proto-udp SHARED ${opentrack-proto-udp-c} ${opentrack-proto-udp-moc} ${opentrack-proto-udp-uih} ${opentrack-proto-udp-rcc})