summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2015-06-10 12:13:25 +0200
committerStanislaw Halik <sthalik@misaki.pl>2015-06-10 12:13:25 +0200
commite324873fefce3a6aef8919861cf17862d1645823 (patch)
tree6d09a3110842d84b2d940d5e69282037ae00d5d5 /CMakeLists.txt
parentb5419b79f5bf4d90085f2e5da5fe1b9aba2e6480 (diff)
cmake: link sixense dynamically for hydra
Previously, .dll was included anyway despite static link. There's a binutils 2.25 bug breaking linking against that sixense.lib, and binutils HEAD has LTO breakage instead. We don't need sixense_utils so remove that from build.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 11 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fcbc266f..4118d9d7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -367,9 +367,12 @@ if(SDK_HYDRA)
target_include_directories(opentrack-tracker-hydra SYSTEM PUBLIC ${SDK_HYDRA}/include ${SDK_HYDRA}/include/sixense_utils)
if(WIN32)
target_link_libraries(opentrack-tracker-hydra
- "${SDK_HYDRA}/lib/win32/release_dll/sixense.lib"
- "${SDK_HYDRA}/lib/win32/release_dll/sixense_utils.lib")
- install(FILES "${SDK_HYDRA}/bin/win32/release_dll/sixense.dll" "${SDK_HYDRA}/bin/win32/release_dll/sixense_utils.dll" DESTINATION .)
+ "${SDK_HYDRA}/bin/win32/release_dll/sixense.dll"
+ #"${SDK_HYDRA}/bin/win32/release_dll/sixense_utils.dll"
+ )
+ install(FILES "${SDK_HYDRA}/bin/win32/release_dll/sixense.dll"
+ #"${SDK_HYDRA}/bin/win32/release_dll/sixense_utils.dll"
+ DESTINATION .)
else()
if(SDK_HYDRA_AMD64)
set(underscore-sixtyfour _x64)
@@ -387,10 +390,13 @@ if(SDK_HYDRA)
endif()
install(FILES
"${SDK_HYDRA}/lib/${sixense-plat}${underscore-sixtyfour}/release${underscore-dll}/libsixense${underscore-sixtyfour}.${soext}"
- "${SDK_HYDRA}/lib/${sixense-plat}${underscore-sixtyfour}/release${underscore-dll}/libsixense_utils${underscore-sixtyfour}.${soext}"
+ #"${SDK_HYDRA}/lib/${sixense-plat}${underscore-sixtyfour}/release${underscore-dll}/libsixense_utils${underscore-sixtyfour}.${soext}"
DESTINATION .
)
- target_link_libraries(opentrack-tracker-hydra "${SDK_HYDRA}/lib/${sixense-plat}${underscore-sixtyfour}/release${underscore-dll}/libsixense${underscore-sixtyfour}.${soext}" "${SDK_HYDRA}/lib/${sixense-plat}${underscore-sixtyfour}/release${underscore-dll}/libsixense_utils${underscore-sixtyfour}.${soext}")
+ target_link_libraries(opentrack-tracker-hydra
+ "${SDK_HYDRA}/lib/${sixense-plat}${underscore-sixtyfour}/release${underscore-dll}/libsixense${underscore-sixtyfour}.${soext}"
+ #"${SDK_HYDRA}/lib/${sixense-plat}${underscore-sixtyfour}/release${underscore-dll}/libsixense_utils${underscore-sixtyfour}.${soext}"
+ )
endif()
endif()