summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2015-10-28 13:45:21 +0100
committerStanislaw Halik <sthalik@misaki.pl>2015-10-28 13:45:21 +0100
commitee5a2b5cd1e93a2133697445aa68f40539c902e2 (patch)
tree4915151ee7682f9b9a449192d127ac2185dfae2a /CMakeLists.txt
parent192e1131873e66d2118afd7a6e13e5701053a4d0 (diff)
buffer flush
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt38
1 files changed, 35 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 420c9067..766d23cb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -187,6 +187,7 @@ endif()
SET(SDK_HYDRA "" CACHE PATH "libSixense path for Razer Hydra")
SET(SDK_HYDRA_AMD64 FALSE CACHE BOOL "whether libSixense is amd64 (else ia-32)")
SET(SDK_RIFT "" CACHE PATH "libOVR path for Oculus Rift")
+SET(SDK_RIFT_025 "" CACHE PATH "libOVR 0.2.5 path for Oculus Rift")
set(SDK_ARUCO_LIBPATH "" CACHE FILEPATH "Aruco paper marker tracker static library path")
@@ -426,6 +427,37 @@ endif()
link_with_dinput8(opentrack-tracker-joystick)
+if(SDK_RIFT_025)
+ set(link-flags)
+ set(c-flags)
+ if(APPLE)
+ set(link-flags "-framework CoreFoundation -framework CoreGraphics -framework IOKit -framework Quartz")
+ set(c-flags "-fno-strict-aliasing")
+ else()
+ if(NOT MSVC)
+ set(c-flags "-fno-strict-aliasing")
+ endif()
+ endif()
+ opentrack_library(opentrack-tracker-rift-025 ftnoir_tracker_rift-025 LINK ${link-flags} COMPILE ${c-flags})
+ target_include_directories(opentrack-tracker-rift-025 SYSTEM PUBLIC ${SDK_RIFT_025}/Include ${SDK_RIFT_025}/Src)
+ if(WIN32)
+ if(MSVC)
+ set(ext lib)
+ set(p)
+ else()
+ set(ext a)
+ set(p lib)
+ endif()
+ target_link_libraries(opentrack-tracker-rift-025 ${SDK_RIFT_025}/${p}LibOVR.${ext} winmm setupapi ws2_32 imagehlp wbemuuid)
+ else()
+ if(NOT APPLE)
+ target_link_libraries(opentrack-tracker-rift-025 ${SDK_RIFT_025}/libLibOVR.a udev Xinerama)
+ else()
+ target_link_libraries(opentrack-tracker-rift-025 ${SDK_RIFT_025}/libLibOVR.a)
+ endif()
+ endif()
+endif()
+
if(SDK_RIFT)
set(link-flags)
set(c-flags)
@@ -433,9 +465,9 @@ if(SDK_RIFT)
set(link-flags "-framework CoreFoundation -framework CoreGraphics -framework IOKit -framework Quartz")
set(c-flags "-fno-strict-aliasing")
else()
- if(NOT MSVC)
- set(c-flags "-fno-strict-aliasing")
- endif()
+ if(NOT MSVC)
+ set(c-flags "-fno-strict-aliasing")
+ endif()
endif()
opentrack_library(opentrack-tracker-rift ftnoir_tracker_rift LINK ${link-flags} COMPILE ${c-flags})
target_include_directories(opentrack-tracker-rift SYSTEM PUBLIC ${SDK_RIFT}/Include ${SDK_RIFT}/Src)