summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2013-04-03 17:55:31 +0200
committerStanislaw Halik <sthalik@misaki.pl>2013-04-03 17:55:31 +0200
commit946d1c0b1f914ccffd9589a4f70de9d1ab5c6acc (patch)
treebefe7057078f152a5dcd2ff3dd0dba35fe99a92c /CMakeLists.txt
parentd01b4b77c5094f885e19106d35a9bf1fe9cbb1ca (diff)
Fix FaceAPI build issues
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index adc0810d..54bb79fd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -92,10 +92,12 @@ if(NOT SDK_FACEAPI_ONLY)
endif()
if(WIN32)
- set(CMAKE_RC_COMPILER_INIT windres)
ENABLE_LANGUAGE(RC)
if(CMAKE_COMPILER_IS_GNUCXX OR CMAKE_COMPILER_IS_GNUCC)
+ set(CMAKE_RC_COMPILER_INIT windres)
SET(CMAKE_RC_COMPILE_OBJECT "<CMAKE_RC_COMPILER> <FLAGS> -O coff <DEFINES> -i <SOURCE> -o <OBJECT>")
+ else()
+ set(CMAKE_RC_COMPILER_INIT rc)
endif()
endif(WIN32)