summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2015-10-06 05:37:46 +0200
committerStanislaw Halik <sthalik@misaki.pl>2015-10-06 05:37:46 +0200
commit9f177ce1906121bbc7c96372486fdce3d2926b76 (patch)
treee2f45d4199c0846ad31c832248dcbd3872e19dbe /CMakeLists.txt
parentcd6315dfe30059dfbd25185fc7d57feb2bce5f24 (diff)
parent2b143a2cea018f6c62800fcb931cc950853728c7 (diff)
Merge branch 'unstable' into trackhat-ui
* unstable: un-bitrot installer support
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5974adef..b48ac0cf 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,8 @@ if(GIT_FOUND)
git_describe(OPENTRACK__COMMIT --tags --always)
endif()
+file(WRITE ${CMAKE_BINARY_DIR}/opentrack-version.h "#define OPENTRACK_VERSION \"${OPENTRACK__COMMIT}\"")
+
SET(CMAKE_BUILD_WITH_INSTALL_RPATH TRUE)
set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
SET(CMAKE_SKIP_INSTALL_RPATH FALSE)