summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2015-07-06 10:42:28 +0200
committerStanislaw Halik <sthalik@misaki.pl>2015-07-06 10:47:48 +0200
commitfcb8ca75c0c274be2321f0ba91e9f129ae63e354 (patch)
tree61dcae88917894e00da2c1e622a26567e1a4e01c /CMakeLists.txt
parentfaab09446c5c26b96e59218abc34b1dc24727418 (diff)
ht: initial camera dialog
It doesn't work while tracking. Can't pass DirectShow handle through shared memory.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c45163dc..7046c549 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -367,11 +367,13 @@ if(OpenCV_FOUND)
target_link_libraries(opentrack-filter-kalman ${OpenCV_LIBS})
target_include_directories(opentrack-filter-kalman SYSTEM PUBLIC ${OpenCV_INCLUDE_DIRS})
-endif()
-opentrack_library(opentrack-tracker-ht ftnoir_tracker_ht)
-target_link_libraries(opentrack-tracker-ht opentrack-compat)
-link_with_dinput8(opentrack-tracker-ht)
+ opentrack_library(opentrack-tracker-ht ftnoir_tracker_ht)
+ target_link_libraries(opentrack-tracker-ht opentrack-compat)
+ link_with_dinput8(opentrack-tracker-ht)
+ target_link_libraries(opentrack-tracker-ht ${OpenCV_LIBS})
+ target_include_directories(opentrack-tracker-ht SYSTEM PUBLIC ${OpenCV_INCLUDE_DIRS})
+endif()
link_with_dinput8(opentrack-tracker-joystick)