summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2013-10-24 22:06:46 +0200
committerStanislaw Halik <sthalik@misaki.pl>2013-10-24 22:06:46 +0200
commit949fa1b35acdd9d9ebfca66fb3e893dbd98376e6 (patch)
tree5e81c5fdf73e0cc4e931b528bb8c0f7096abe2c1 /CMakeLists.txt
parent387e9729f29cd09ea6e3390f1177886de560de98 (diff)
fix CRT hell
Signed-off-by: Stanislaw Halik <sthalik@misaki.pl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 885e9a96..4b524310 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -598,6 +598,10 @@ endif()
target_link_libraries(opentrack opentrack-qxt-mini)
endif()
+ if(MSVC)
+ SET_TARGET_PROPERTIES(opentrack PROPERTIES LINK_FLAGS "/NODEFAULTLIB:LIBCMT")
+ endif()
+
if(UNIX)
install(TARGETS opentrack-qxt-mini DESTINATION .)
endif()