summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2014-06-12 06:21:29 +0200
committerStanislaw Halik <sthalik@misaki.pl>2014-06-12 06:21:29 +0200
commitc450fe815e8a20433d2a60ac5df4dd25e51086ad (patch)
tree2c47dc12425dc9afc2f350b5ffc6c960974af7ad /CMakeLists.txt
parent67930efbb74f95ede7b24ac8b3c3e5fc4a9ea95d (diff)
detect libevdev via pkgconfig
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7e101bad..2f697b05 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,6 +5,7 @@ include(CMakeParseArguments)
set(CMAKE_MODULE_PATH "${CMAKE_MODULE_PATH}" "${CMAKE_SOURCE_DIR}/cmake/")
include(GetGitRevisionDescription)
+include(FindPkgConfig)
find_package(Git QUIET)
if(GIT_FOUND)
git_describe(OPENTRACK__COMMIT --tags --always)
@@ -331,7 +332,9 @@ endif()
if(SDK_ENABLE_LIBEVDEV)
opentrack_library(opentrack-proto-libevdev)
- target_link_libraries(opentrack-proto-libevdev evdev)
+ pkg_check_modules(libevdev REQUIRED QUIET libevdev)
+ include_directories(${LibXML++_INCLUDE_DIRS})
+ target_link_libraries(opentrack-proto-libevdev ${libevdev-LIBRARIES})
endif()
if(SDK_FSUIPC)