summaryrefslogtreecommitdiffhomepage
path: root/cv/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2016-07-31 13:48:09 +0200
committerStanislaw Halik <sthalik@misaki.pl>2016-07-31 13:48:09 +0200
commitfa528a7ebafc9b5751deda05c02aec43a9a45ead (patch)
treee23a0e74592670b23c5df3c6b58895255aaad581 /cv/CMakeLists.txt
parentccafc5f054733e883bb0ef8b0c698b4c9c86fff9 (diff)
tracker/{aruco, pt}, compat, api: move opencv camera class to cv module
Diffstat (limited to 'cv/CMakeLists.txt')
-rw-r--r--cv/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/cv/CMakeLists.txt b/cv/CMakeLists.txt
new file mode 100644
index 00000000..0f29c4f2
--- /dev/null
+++ b/cv/CMakeLists.txt
@@ -0,0 +1,6 @@
+find_package(OpenCV 3.0 QUIET)
+if(OpenCV_FOUND)
+ opentrack_boilerplate(opentrack-cv STATIC)
+ target_link_libraries(opentrack-cv ${OpenCV_LIBS})
+ target_include_directories(opentrack-cv SYSTEM PUBLIC ${OpenCV_INCLUDE_DIRS})
+endif()