summaryrefslogtreecommitdiffhomepage
path: root/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2015-10-30 09:01:32 +0100
committerStanislaw Halik <sthalik@misaki.pl>2015-10-30 09:01:32 +0100
commitd785d3616500d5846ac8c5f5a6347da832a593b4 (patch)
treeac670a125c5b880ad7e4b4f24a8635da4e66f0da /gui/CMakeLists.txt
parent232c2ba8aca7900eaa950c48813ddfaca8a749a8 (diff)
parent9b736d361bcde7a2ddaf3fe54b471c0e658e94f4 (diff)
Merge branch 'unstable' into trackhat
* unstable: cmake: cleanup hydra rename gui directory move to subdirectory-based build system cmake: switch to GNU CC 5.2.0 in mingw-w64 toolchain file rift-080: forgot ovr_Initialize() rift 025: fix name
Diffstat (limited to 'gui/CMakeLists.txt')
-rw-r--r--gui/CMakeLists.txt67
1 files changed, 67 insertions, 0 deletions
diff --git a/gui/CMakeLists.txt b/gui/CMakeLists.txt
new file mode 100644
index 00000000..0b20bc9c
--- /dev/null
+++ b/gui/CMakeLists.txt
@@ -0,0 +1,67 @@
+opentrack_boilerplate(opentrack NO-LIBRARY)
+
+if(UNIX OR APPLE)
+ target_include_directories(opentrack "${CMAKE_SOURCE_DIR}/qxt-mini")
+ if(APPLE)
+ set(qxt-plat mac)
+ else()
+ set(qxt-plat x11)
+ endif()
+ file(GLOB qxt-mini-c
+ ${CMAKE_SOURCE_DIR}/qxt-mini/*.h
+ ${CMAKE_SOURCE_DIR}/qxt-mini/qxtglobalshortcut.cpp
+ ${CMAKE_SOURCE_DIR}/qxt-mini/plat/qxtglobalshortcut_${qxt-plat}.cpp
+ )
+ opentrack_qt(qxt-mini)
+ add_library(opentrack-qxt-mini STATIC ${qxt-mini-all})
+ target_link_libraries(opentrack-qxt-mini ${MY_QT_LIBS})
+ if(NOT APPLE)
+ target_link_libraries(opentrack-qxt-mini X11)
+ endif()
+endif()
+
+if(WIN32)
+ SET(SDK_CONSOLE_DEBUG FALSE CACHE BOOL "Console window visible at runtime")
+endif()
+
+if(WIN32 AND NOT SDK_CONSOLE_DEBUG)
+ set(opentrack-win32-executable WIN32)
+else()
+ set(opentrack-win32-executable "")
+endif()
+
+if(UNIX OR APPLE)
+ list(APPEND opentrack-c ${CMAKE_SOURCE_DIR}/qxt-mini/qxtglobalshortcut.h)
+endif()
+opentrack_qt(opentrack)
+add_executable(opentrack ${opentrack-win32-executable} ${opentrack-all})
+opentrack_compat(opentrack)
+if(NOT WIN32)
+ set_target_properties(opentrack PROPERTIES SUFFIX ".bin")
+endif()
+
+target_link_libraries(opentrack
+ opentrack-api opentrack-version opentrack-pose-widget opentrack-spline-widget
+ opentrack-tracker-pt opentrack-filter-accela
+)
+
+if(APPLE)
+ SET_TARGET_PROPERTIES(opentrack-qxt-mini PROPERTIES LINK_FLAGS "-framework Carbon -framework CoreFoundation")
+endif()
+if(UNIX OR APPLE)
+ target_link_libraries(opentrack opentrack-qxt-mini)
+endif()
+link_with_dinput8(opentrack)
+target_link_libraries(opentrack ${MY_QT_LIBS})
+
+if(APPLE)
+ # for process detector
+ target_link_libraries(opentrack proc)
+endif()
+
+if(LINUX)
+ # for process detector
+ target_link_libraries(opentrack procps)
+endif()
+
+install(TARGETS opentrack DESTINATION .)