summaryrefslogtreecommitdiffhomepage
path: root/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2017-06-07 03:55:46 +0200
committerStanislaw Halik <sthalik@misaki.pl>2017-06-07 03:55:46 +0200
commit29857b87efdec4ed6a4adb8162d2428460eec53a (patch)
tree0738b0504e1c9ce42cc5f5455ee34552576ee6cc /gui/CMakeLists.txt
parenta1ee9c7a2ebc5d450a7428c8f8d7ab6864cb9497 (diff)
cmake: cleanup
We now inherit parent process' console. No need for the cmake cache option.
Diffstat (limited to 'gui/CMakeLists.txt')
-rw-r--r--gui/CMakeLists.txt12
1 files changed, 1 insertions, 11 deletions
diff --git a/gui/CMakeLists.txt b/gui/CMakeLists.txt
index 7d140dd6..d0cba4ac 100644
--- a/gui/CMakeLists.txt
+++ b/gui/CMakeLists.txt
@@ -1,14 +1,4 @@
-if(MSVC OR (NOT SDK_CONSOLE_DEBUG AND WIN32))
- set(console "")
-else()
- set(console WIN32-CONSOLE)
-endif()
-
-if(WIN32)
- SET(SDK_CONSOLE_DEBUG FALSE CACHE BOOL "Console window visible at runtime")
-endif()
-
-otr_module(user-interface EXECUTABLE BIN ${console})
+otr_module(user-interface EXECUTABLE BIN)
set_target_properties(opentrack-user-interface PROPERTIES
SUFFIX "${opentrack-binary-suffix}"