summaryrefslogtreecommitdiffhomepage
path: root/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2016-05-23 09:42:23 +0200
committerStanislaw Halik <sthalik@misaki.pl>2016-05-23 09:49:28 +0200
commitab57277ad5a67d9267cf83c7df49bade163f90d6 (patch)
tree534e18db373e677f532350fb060c722d374b8c02 /gui/CMakeLists.txt
parentfadbc9f71f21e5147825dd5db7bf5e4c68a58178 (diff)
cmake{/gui,}: make boilerplate usable for building the executable
Diffstat (limited to 'gui/CMakeLists.txt')
-rw-r--r--gui/CMakeLists.txt20
1 files changed, 2 insertions, 18 deletions
diff --git a/gui/CMakeLists.txt b/gui/CMakeLists.txt
index e014e00b..3b2e60e1 100644
--- a/gui/CMakeLists.txt
+++ b/gui/CMakeLists.txt
@@ -10,9 +10,7 @@ else()
set(opentrack-win32-executable "")
endif()
-opentrack_qt(opentrack)
add_executable(opentrack ${opentrack-win32-executable} ${opentrack-all})
-opentrack_compat(opentrack)
if(NOT WIN32)
set_target_properties(opentrack PROPERTIES SUFFIX ".bin")
@@ -21,8 +19,6 @@ endif()
target_link_libraries(opentrack
opentrack-spline-widget
opentrack-pose-widget
- opentrack-api
- opentrack-compat
opentrack-version
)
@@ -37,18 +33,6 @@ if(LINUX)
target_link_libraries(opentrack procps)
endif()
-set(c-props)
-set(l-props)
-if(CMAKE_COMPILER_IS_GNUCXX)
- set(c-props "-fvisibility=hidden ")
- if(NOT APPLE)
- set(l-props "-Wl,--as-needed")
- endif()
-endif()
-
-set_target_properties(opentrack PROPERTIES
- LINK_FLAGS "${l-props}"
- COMPILE_FLAGS "${c-props}"
-)
-
+opentrack_boilerplate(opentrack STAGE2)
install(TARGETS opentrack DESTINATION .)
+