summaryrefslogtreecommitdiffhomepage
path: root/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2018-01-11 14:36:07 +0100
committerStanislaw Halik <sthalik@misaki.pl>2018-01-11 14:36:07 +0100
commite1d6232217120be879bb639681f61e46e2d48580 (patch)
treed186ffc3dd72de6e4703d584a41971107ca8389b /gui/CMakeLists.txt
parent98ef185a5c9075720acb54ec1c2e5fec6e4ab440 (diff)
cmake, gui, main: make user interface reusable
The work isn't complete. We need moving out all non-reusable parts away and only keeping user interface logic in a class.
Diffstat (limited to 'gui/CMakeLists.txt')
-rw-r--r--gui/CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/gui/CMakeLists.txt b/gui/CMakeLists.txt
index d0cba4ac..954fa67a 100644
--- a/gui/CMakeLists.txt
+++ b/gui/CMakeLists.txt
@@ -1,9 +1,4 @@
-otr_module(user-interface EXECUTABLE BIN)
-
-set_target_properties(opentrack-user-interface PROPERTIES
- SUFFIX "${opentrack-binary-suffix}"
- OUTPUT_NAME "opentrack"
- )
+otr_module(user-interface BIN)
target_link_libraries(opentrack-user-interface
opentrack-migration