summaryrefslogtreecommitdiffhomepage
path: root/macosx/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2015-11-01 08:56:23 +0100
committerStanislaw Halik <sthalik@misaki.pl>2015-11-01 08:56:23 +0100
commit7e3807d048c5e0a8e0aa64fb49807bf5dfd11fc1 (patch)
tree22029a8b36a593585dcd962b81ff80199a4f9984 /macosx/CMakeLists.txt
parent664aefb41351113fbd43962aa534befe18ff9d4a (diff)
parent0ff658f908bc3e07bca9987dfd5b7c365b7d8353 (diff)
Merge branch 'unstable' into trackhat
Diffstat (limited to 'macosx/CMakeLists.txt')
-rw-r--r--macosx/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/macosx/CMakeLists.txt b/macosx/CMakeLists.txt
new file mode 100644
index 00000000..214ea676
--- /dev/null
+++ b/macosx/CMakeLists.txt
@@ -0,0 +1,9 @@
+if(APPLE)
+ install(CODE "
+ execute_process(COMMAND /bin/sh \"${CMAKE_SOURCE_DIR}/macosx/make-app-bundle.sh\"
+ \"${CMAKE_SOURCE_DIR}/macosx\"
+ \"${CMAKE_INSTALL_PREFIX}\"
+ \"${CMAKE_BINARY_DIR}\"
+ \"${OPENTRACK_COMMIT}\")
+ ")
+endif()