summaryrefslogtreecommitdiffhomepage
path: root/main-window/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2018-07-31 12:45:54 +0200
committerStanislaw Halik <sthalik@misaki.pl>2018-07-31 12:45:54 +0200
commitbad2a3e97a92b32c163510e7a0764034c1f87d80 (patch)
tree8f42f5ab9b9e3bff768cd375997b82d9ef1d2ec7 /main-window/CMakeLists.txt
parenta40de1a8987a982780daf207369fdd457de17fa1 (diff)
add maintainer mode for building WIP main-window mixins
Diffstat (limited to 'main-window/CMakeLists.txt')
-rw-r--r--main-window/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/main-window/CMakeLists.txt b/main-window/CMakeLists.txt
index f69080f1..c9228536 100644
--- a/main-window/CMakeLists.txt
+++ b/main-window/CMakeLists.txt
@@ -1,4 +1,6 @@
-otr_module(main-window BIN NO-INSTALL)
-foreach(k user-interface logic pose-widget migration spline)
- target_link_libraries(${self} opentrack-${k})
-endforeach()
+if(opentrack_maintainer-mode)
+ otr_module(main-window BIN NO-INSTALL)
+ foreach(k user-interface logic pose-widget migration spline)
+ target_link_libraries(${self} opentrack-${k})
+ endforeach()
+endif()