summaryrefslogtreecommitdiffhomepage
path: root/options/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2016-08-17 21:28:45 +0200
committerStanislaw Halik <sthalik@misaki.pl>2016-08-17 21:34:53 +0200
commitcb33be1c50b68d6022f344ddac923c7aac3a11d5 (patch)
tree1840e3f9829aa69f10f81804f655e97be3f2eca8 /options/CMakeLists.txt
parent41ba8aa5329c16a797140dc23650ef45f42753a3 (diff)
move options framework into its own library
- adjust usages - add support for QList signals and metatype
Diffstat (limited to 'options/CMakeLists.txt')
-rw-r--r--options/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/options/CMakeLists.txt b/options/CMakeLists.txt
new file mode 100644
index 00000000..25749bf5
--- /dev/null
+++ b/options/CMakeLists.txt
@@ -0,0 +1,4 @@
+opentrack_boilerplate(opentrack-options NO-COMPAT BIN)
+if(NOT WIN32 AND NOT APPLE)
+ target_link_libraries(opentrack-options rt)
+endif()