summaryrefslogtreecommitdiffhomepage
path: root/proto-iokit-foohid/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <git@eikeziller.de>2017-11-19 21:18:26 +0100
committerEike Ziller <git@eikeziller.de>2017-11-23 20:23:28 +0100
commit7bacbdf10b97040c9ed282a22485759bd082fa63 (patch)
tree2a02884f633ddbc7ede387a5bf2aa8d7b0396e5f /proto-iokit-foohid/CMakeLists.txt
parentf548847ea43006b2dc540e84d11d3c3662a94148 (diff)
Add virtual joystick output for macOS
Based of the foohid IOKit driver for implementing virtual HID devices. Issue: #236
Diffstat (limited to 'proto-iokit-foohid/CMakeLists.txt')
-rw-r--r--proto-iokit-foohid/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/proto-iokit-foohid/CMakeLists.txt b/proto-iokit-foohid/CMakeLists.txt
new file mode 100644
index 00000000..b997bf60
--- /dev/null
+++ b/proto-iokit-foohid/CMakeLists.txt
@@ -0,0 +1,4 @@
+IF(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
+ otr_module(proto-iokit-foohid)
+ otr_prop(TARGET opentrack-proto-iokit-foohid LINK_FLAGS "-framework IOKit")
+endif()