summaryrefslogtreecommitdiffhomepage
path: root/proto-libevdev/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2015-10-30 09:16:32 +0100
committerStanislaw Halik <sthalik@misaki.pl>2015-10-30 09:16:32 +0100
commit0739d5b595be9492c1e574192eba12174111e52c (patch)
tree01225d2335ff784b35b59a5438f8ea1e07535486 /proto-libevdev/CMakeLists.txt
parent05b2f05b72c706908e961eff8c0e4aa70dcadbd3 (diff)
also rename protocol -> proto
Diffstat (limited to 'proto-libevdev/CMakeLists.txt')
-rw-r--r--proto-libevdev/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/proto-libevdev/CMakeLists.txt b/proto-libevdev/CMakeLists.txt
new file mode 100644
index 00000000..960a1271
--- /dev/null
+++ b/proto-libevdev/CMakeLists.txt
@@ -0,0 +1,10 @@
+if(LINUX OR APPLE)
+ set(SDK_ENABLE_LIBEVDEV FALSE CACHE BOOL "libevdev virtual joystick protocol support")
+ if(SDK_ENABLE_LIBEVDEV)
+ include(FindPkgConfig)
+ opentrack_boilerplate(opentrack-proto-libevdev)
+ pkg_check_modules(libevdev REQUIRED QUIET libevdev)
+ target_link_libraries(opentrack-proto-libevdev ${libevdev_LIBRARIES})
+ include_directories(opentrack-proto-libevdev SYSTEM PUBLIC ${libevdev_INCLUDE_DIRS})
+ endif()
+endif()