summaryrefslogtreecommitdiffhomepage
path: root/proto-wine/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2016-07-06 14:00:47 +0200
committerStanislaw Halik <sthalik@misaki.pl>2016-07-06 14:00:47 +0200
commitcbe565160d4d540d8c0cc611ecc8c752f122ca7b (patch)
treea1f603b5eab5474250ce74b12cf4950dce4038bf /proto-wine/CMakeLists.txt
parent5604986bf37b131397d3f168e7eac6a22292b2ea (diff)
proto-wine, x-plane-plugin: fix install prefix
Diffstat (limited to 'proto-wine/CMakeLists.txt')
-rw-r--r--proto-wine/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/proto-wine/CMakeLists.txt b/proto-wine/CMakeLists.txt
index 1ed8fac6..36550e6e 100644
--- a/proto-wine/CMakeLists.txt
+++ b/proto-wine/CMakeLists.txt
@@ -2,6 +2,7 @@ if(NOT WIN32)
set(SDK_WINE_PREFIX "" CACHE PATH "Wine install prefix")
set(SDK_WINE_NO_WRAPPER FALSE CACHE BOOL "disable Wine wrapper -- use Wine only for X-Plane")
if(SDK_WINE_PREFIX)
+ include(opentrack-hier)
opentrack_boilerplate(opentrack-proto-wine)
target_link_libraries(opentrack-proto-wine opentrack-compat opentrack-csv)
if(NOT SDK_WINE_NO_WRAPPER)
@@ -20,7 +21,7 @@ if(NOT WIN32)
add_custom_target(wine-wrapper ALL DEPENDS opentrack-wrapper-wine.exe.so)
add_dependencies(opentrack-proto-wine wine-wrapper)
add_dependencies(wine-wrapper opentrack-compat)
- install(FILES "${CMAKE_CURRENT_BINARY_DIR}/opentrack-wrapper-wine.exe.so" DESTINATION .)
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/opentrack-wrapper-wine.exe.so" DESTINATION ${opentrack-hier-pfx})
endif()
endif()
endif()