summaryrefslogtreecommitdiffhomepage
path: root/qxt-mini/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2015-11-01 08:19:00 +0100
committerStanislaw Halik <sthalik@misaki.pl>2015-11-01 08:49:12 +0100
commitf14becff3653fa71911303fb0898a5d5a9cdfe95 (patch)
treea4fb1db70720f4fdf3a3ef7d515683c7e8bfc083 /qxt-mini/CMakeLists.txt
parent882dae825773963ef44bfee61ca990fddbb94d02 (diff)
qxt-mini: make own module
Diffstat (limited to 'qxt-mini/CMakeLists.txt')
-rw-r--r--qxt-mini/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/qxt-mini/CMakeLists.txt b/qxt-mini/CMakeLists.txt
new file mode 100644
index 00000000..2fe5993b
--- /dev/null
+++ b/qxt-mini/CMakeLists.txt
@@ -0,0 +1,12 @@
+if(UNIX OR APPLE)
+ opentrack_boilerplate(opentrack-qxt-mini
+ NO-LINKER-SCRIPT NO-COMPAT
+ COMPILE "-DQXT_BUILD -DBUILD_QXT_GUI"
+ )
+ if(NOT APPLE)
+ target_link_libraries(opentrack-qxt-mini X11)
+ else()
+ set_target_properties(opentrack-qxt-mini PROPERTIES LINK_FLAGS
+ "-framework Carbon -framework CoreFoundation")
+ endif()
+endif()