summaryrefslogtreecommitdiffhomepage
path: root/spline-widget/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2015-11-01 08:39:46 +0100
committerStanislaw Halik <sthalik@misaki.pl>2015-11-01 08:49:12 +0100
commite04fe7d7b412c502c30c3eaf9d54b0eebf708d2b (patch)
tree0c61ecb4c612e8717d4aef605b1f316ca6881f97 /spline-widget/CMakeLists.txt
parentcc16fd0121fe79ae1fd9539a606c19827f64bc23 (diff)
cmake: less boilerplate, link dynamically
Diffstat (limited to 'spline-widget/CMakeLists.txt')
-rw-r--r--spline-widget/CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/spline-widget/CMakeLists.txt b/spline-widget/CMakeLists.txt
index 522491ea..03706d91 100644
--- a/spline-widget/CMakeLists.txt
+++ b/spline-widget/CMakeLists.txt
@@ -1,6 +1 @@
-opentrack_boilerplate(opentrack-spline-widget NO-LIBRARY)
-opentrack_qt(opentrack-spline-widget)
-add_library(opentrack-spline-widget STATIC ${opentrack-spline-widget-all})
-opentrack_compat(opentrack-spline-widget)
-target_include_directories(opentrack-spline-widget PUBLIC qfunctionconfigurator/)
-target_link_libraries(opentrack-spline-widget ${MY_QT_LIBS})
+opentrack_boilerplate(opentrack-spline-widget NO-LINKER-SCRIPT)