summaryrefslogtreecommitdiffhomepage
path: root/tracker-neuralnet/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2021-08-11 23:06:11 +0000
committerGitHub <noreply@github.com>2021-08-11 23:06:11 +0000
commit6795178b3f5a1daff130e374e5046ce75c55c1ce (patch)
tree55f7fbc7428031e71875c8a621eefd57b61c0dfa /tracker-neuralnet/CMakeLists.txt
parentadef75d81c7606dd69f5d619c577b634b2868070 (diff)
parent07e64c37487b6c99b0425b8e4014af63529459cf (diff)
Merge pull request #1307 from DaWelter/improved-onnx-findscript
cmake: improve the FindONNXRuntime script and install the ONNX dll
Diffstat (limited to 'tracker-neuralnet/CMakeLists.txt')
-rw-r--r--tracker-neuralnet/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/tracker-neuralnet/CMakeLists.txt b/tracker-neuralnet/CMakeLists.txt
index bcdbbc81..70850925 100644
--- a/tracker-neuralnet/CMakeLists.txt
+++ b/tracker-neuralnet/CMakeLists.txt
@@ -5,16 +5,20 @@ find_package(ONNXRuntime QUIET)
if(OpenCV_FOUND AND ONNXRuntime_FOUND AND OpenMP_FOUND)
otr_module(tracker-neuralnet)
+
target_link_libraries(${self}
opentrack-cv
- onnxruntime
+ onnxruntime::onnxruntime
${OpenCV_LIBS}
OpenMP::OpenMP_C
)
+
install(
FILES "models/head-localizer.onnx"
"models/head-pose.onnx"
DESTINATION "${opentrack-libexec}/models"
PERMISSIONS ${opentrack-perms-file}
)
+
+ otr_install_lib("${ONNXRuntime_RUNTIME}" ".")
endif()