summaryrefslogtreecommitdiffhomepage
path: root/tracker-neuralnet/CMakeLists.txt
diff options
context:
space:
mode:
authorGuillaume Dollé <dolle.guillaume@gmail.com>2021-08-02 02:21:01 +0200
committerGuillaume Dollé <dolle.guillaume@gmail.com>2021-08-02 02:28:45 +0200
commit1e3d62e04f78e2d0e22b3ceb67aaf20a03f18bbc (patch)
treec4ea500f2b42636464b844bd831b6382f931e0ba /tracker-neuralnet/CMakeLists.txt
parent489b49e98f013ca495ee8314718df24b67b0e825 (diff)
Fix include path for release package
* Revert include header changes * Address the following review remarks for include path https://github.com/opentrack/opentrack/pull/1306#discussion_r680548570 https://github.com/opentrack/opentrack/pull/1306#discussion_r680548755 https://github.com/opentrack/opentrack/pull/1306#discussion_r680548800 https://github.com/opentrack/opentrack/pull/1306#discussion_r680549144
Diffstat (limited to 'tracker-neuralnet/CMakeLists.txt')
-rw-r--r--tracker-neuralnet/CMakeLists.txt9
1 files changed, 2 insertions, 7 deletions
diff --git a/tracker-neuralnet/CMakeLists.txt b/tracker-neuralnet/CMakeLists.txt
index 36395684..bcdbbc81 100644
--- a/tracker-neuralnet/CMakeLists.txt
+++ b/tracker-neuralnet/CMakeLists.txt
@@ -5,14 +5,9 @@ find_package(ONNXRuntime QUIET)
if(OpenCV_FOUND AND ONNXRuntime_FOUND AND OpenMP_FOUND)
otr_module(tracker-neuralnet)
- target_include_directories(${self}
- SYSTEM PRIVATE
- ${OpenCV_INCLUDE_DIRS}
- ${ONNXRuntime_INCLUDE_DIRS}
- )
target_link_libraries(${self}
- opentrack-cv
- ${ONNXRuntime_LIBRARIES}
+ opentrack-cv
+ onnxruntime
${OpenCV_LIBS}
OpenMP::OpenMP_C
)