summaryrefslogtreecommitdiffhomepage
path: root/tracker-pt/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2018-01-10 06:18:43 +0100
committerStanislaw Halik <sthalik@misaki.pl>2018-01-10 06:18:43 +0100
commit3265f4f14a8348072910c7c812b549064ecaa776 (patch)
treecb5a52aab5bd741bc9e6ad31a9ce93574783823d /tracker-pt/CMakeLists.txt
parent0557e4ff5609f8863738847275ff19c96014b7be (diff)
cv, tracker/{aruco,pt}: link less opencv libs
Diffstat (limited to 'tracker-pt/CMakeLists.txt')
-rw-r--r--tracker-pt/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/tracker-pt/CMakeLists.txt b/tracker-pt/CMakeLists.txt
index abc7fb33..8e6d902b 100644
--- a/tracker-pt/CMakeLists.txt
+++ b/tracker-pt/CMakeLists.txt
@@ -1,6 +1,7 @@
find_package(OpenCV 3.0 QUIET COMPONENTS ${opencv-modules})
if(OpenCV_FOUND)
otr_module(tracker-pt)
- target_link_libraries(opentrack-tracker-pt opentrack-cv ${OpenCV_LIBS})
+ set(modules opencv_core opencv_videoio opencv_imgproc)
+ target_link_libraries(opentrack-tracker-pt opentrack-cv ${modules})
target_include_directories(opentrack-tracker-pt SYSTEM PUBLIC ${OpenCV_INCLUDE_DIRS})
endif()