summaryrefslogtreecommitdiffhomepage
path: root/tracker-pt/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2015-10-30 10:09:58 +0100
committerStanislaw Halik <sthalik@misaki.pl>2015-10-30 10:09:58 +0100
commit36273c6dfdd9a0a22e396b354213eb492886afaf (patch)
tree23152837b6f861d9e0ca667141e8b34cf90398a6 /tracker-pt/CMakeLists.txt
parent3bdd6411060dce095528239acc1812d4e7180371 (diff)
parent48c30a3d75d18e87e39c18cb52961bb37ab6055e (diff)
Merge branch 'unstable' into trackhat
Diffstat (limited to 'tracker-pt/CMakeLists.txt')
-rw-r--r--tracker-pt/CMakeLists.txt12
1 files changed, 7 insertions, 5 deletions
diff --git a/tracker-pt/CMakeLists.txt b/tracker-pt/CMakeLists.txt
index 49943917..79405b4d 100644
--- a/tracker-pt/CMakeLists.txt
+++ b/tracker-pt/CMakeLists.txt
@@ -1,5 +1,7 @@
-find_package(OpenCV 3.0)
-opentrack_boilerplate(opentrack-tracker-pt STATIC)
-target_link_libraries(opentrack-tracker-pt ${OpenCV_LIBS})
-target_include_directories(opentrack-tracker-pt SYSTEM PUBLIC ${OpenCV_INCLUDE_DIRS})
-link_with_dinput8(opentrack-tracker-pt)
+find_package(OpenCV 3.0 QUIET)
+if(OpenCV_FOUND)
+ opentrack_boilerplate(opentrack-tracker-pt STATIC)
+ target_link_libraries(opentrack-tracker-pt ${OpenCV_LIBS})
+ target_include_directories(opentrack-tracker-pt SYSTEM PUBLIC ${OpenCV_INCLUDE_DIRS})
+ link_with_dinput8(opentrack-tracker-pt)
+endif()